3 av 5


Ja, det var den tredje semesterveckan det. 2 veckor kvar av semestern. Få se hur det går.

Köpte ny stol idag


Köpte ny stol idag. Det tog sin tid att montera den, men det gick!

Den gamla stolen får jag släpa ner till nästan överfyllda förrådet.

2 av 5


Ja, det var den andra semester veckan det. 3 veckor kvar av semestern.

Få se hur de kvarvarande veckorna går.

Promenad


Tog en promenad idag istället för att åka hoj. Måste hushålla med milen tills jag gjort servicen.

Fick något bråttom hem på slutet och rusa in på toa.

Passade på att ”raka” skallen innan duschen.

Blev väckt i natt


Hade knappt hunnit somna innan jag blev väckt av vääääääldig högt musik vid 0:55.

Det stod en bil utanför och spelade till 01:10. Hörde massa med röster med.

Grannen mittemot som hade också hört det hade tittat ut genom fönstret sett 7 killar stå och kissa i buskarna. Det var en tjej med i sällskapet.

Hade väldigt svårt att somna om efter det. Gick upp runt 05:45 då jag inte kunde somna om.

Höll på att vattna blommorna runt 06:30 när han kom ut och snackade lite om det.

Semester


Runt 11:45 gick jag på semester 🙂 Få se om jag kan koppla bort jobbet. Har inte avinstallerat mejlappen, men jag stängde aviseringar & synkningen och sen flyttade appen till annat fönster så att jag inte blir frestad eller råka klicka på den.

Semestern började jag med att städa och möblera om lite. Sen tog jag en jobbig promenad. Enligt en annan app så har jag gått det 9 trappor upp.

Hade funderat på att ta hojen, men med tanke på att jag endast sov 3 timmar (sammanlagd) i natt så kändes det dumt att åka nånstans.

Blev lite dyrt idag!


På f.m. installerade senaste Windows 10 version 2004. Det tog sin lilla tid. Har hela semestern på mig att kolla vad som är nytt i den!

Har jobbat f.m. denna veckan, nja inte igår, då jag snackade med en leverantör, så det var heldag igår. Sen börjar jag semestern på fredag.

Drog till Gränna efter jobbet (11:45). Det gick bra att åka idag 🙂 Inte så mycket domningar och höften var OK. Mat åt jag inte, vågade inte, även det har känts bättre den här veckan (från måndag e.m.)

Köpte en hel del grejer som jag hade tänkt ge bort. Men det visar sig att det inte blir av, så jag får göra mig av mig knäckebröd, … på annat sätt.

Vrålhungrig gick jag runt för att köpa något att äta. Köpte sallad, men sen såg jag Wagyu biffen. Frestelsen var för stor, så jag köpte en bit trots priset. Istället för sallad åt jag några tunna skivor när jag kom hem. Stekte lite med salt och vitlökspeppar. Förstår varför den var så dyr! Styckade upp resten och lade det i frysen till andra tillfällen jag vill festa till.

Tankade 9,24 liter. Mätarställning: 37935. 9,8 mil blev det idag.

Åkte lite innan senlunch


Tog ledigt några timmar och åkte runt lite.

Det var ingen bra körning. Hade ont, fick mer domningar, … Tänkte mycket på jobbet, tänkte på magen (hur göra om jag måste på toa, …?) Så jag hade inte blicken, …

Sen satt jag och tittade på en live sändning (webinar). Sitter fortfarande medan den som håller i det är på rast! Bra ämne: Patching Microsoft SQL Server and Designing HA/DR Architectures

Mätarställning: 37719. 9,9 mil blev det.

Morgonrunda


Tog en på morgonen. Vaknade strax efter 02:15 och kunde inte somna om. Gick ut 04:15.

Nu blir dusch och frukost!

Pysslade lite


Det blev några rundor till och från förrådet. Plockade fram lite fler mc-kläder och bar ner kläder jag inte använt på länge, och som jag inte kommer att använda förrän vintern.

Möblerade om lite i förrådet och slängde lite små saker. Typ hälften av det jag har där kan slängas. Får vänta till bättre tider. Nu jag lite bättre plats så att jag kan ställa in utemöblerna i hösten i alla fall.

Plockade fram lite prydnadssaker och pysslade lite hemma med.

Blommor


Har gått och väntat för att se vad som växer för blommor i mina lådor, innan jag köper nåt och planterar.

Har tidigare pratat med bovärden och fick erbjudande att få blommor där det är tomt. Gärna sa jag.

Igår såg jag att hon höll på med att plantera några stycken och var ut och pratade en stund.

Pekade på några ställen att där och där håller det på att växa ut något. Det visade sig vara ogräs!

I morse var jag till torget och köpte några plantor själv. Sen var jag ute i regn och hagel och satte in dem.

Tempdb:n larmade i natt med


För andra dagen i rad såg jag larm att tempdb har börjat få ont om utrymme på en AG maskin.

Det var inte så illa som igår. När jag loggade in strax innan 05 (ett par minuter efter att larmet kom) så var det 2 GB/fil ledig. Den krympte med 1MB/5 minut eller så. Den session som käkade utrymmet hade pågått i ca 13 timmar.

Kan det vara det orsakas av att om ArcMap sessionen är i editeringsläge. Är det som en öppen transaktion där det förväntas commit/rollback? Kan det vara så att om man i redigeringsläge så skickas det ingen commit? Att det måste gås ur redigeringsläget för det?

Av det jag minns när jag labbade så var det inte så. Måste ta och labba lite med det, om det inte är så att någon som kan systemet kan säga ja det är så eller nej det inte är så.

Hur som helst så fylldes inte tempdb denna gång och det spred sig inte till andra replikorna.

Dags att beställa ny trimmer


Höll på att trimma håret nyss, när trimmern gick sönder. Lyckades får bort allt genom att fixa det 10-tals gånger.

Det är dags att beställa nytt.

Tempdb var fullt


Såg massa med larm strax efter 03:45. Version Store is full …

Felsökningen gav inte samma resultat som det brukar vara och mina åtgärder (gav mig på den AG som brukar orsaka sånt, att tempdb blir fullt) var felaktiga.

Hade kört

USE [master]
GO
ALTER AVAILABILITY GROUP [AG_namnet]
MODIFY REPLICA ON N’Replika 1′ WITH (SECONDARY_ROLE (ALLOW_CONNECTIONS = NO))
GO

Så jag fick ändra tillbaka

USE [master]
GO
ALTER AVAILABILITY GROUP [AG_namnet]
MODIFY REPLICA ON N’Replika 1′ WITH (SECONDARY_ROLE (ALLOW_CONNECTIONS = ALL))
GO

Hittade en session som orsakade det hela och tog bort sessionen. Fick tillbaka ca 40 GB utrymme. Det var dryga 20 MB när jag började felsöka.

Lite pyssel tidig på morgonen


Passade på att flytta ut 2 växter och plantera dem i ett hörn. Får se om de överlever ute!

Strul, …


Det har varit många avbrott på wifi/internet. Blev utslängt från Skype flera gånger idag. Till slut plockade jag nätverkskabeln, den längsta jag hade. Men så hade jag ingen anslutning från den som är närmast så jag fick dra från hallen. Få se om jag snubbar på den!

Sen var jag hämtade paketet. Eller ja, det enligt appen var paketet framme, men inte jag kom till Hemköp. Så jag gick hem. Senare under mötet fick jag sms att paketet hade kommit så jag gick efter jobbet och hämtade det.

Telefonen är nu uppdaterad och jag läste tillbaka en backup på den. Men sen kom flera tal avbrott när den försökte ladda ner mina appar. Hade ingen internet anslutning. Valde att starta om routern ett antal gånger. Nu fortsätter nerladdningen. Få se om jag får flera avbrott. Tappade internetanslutningen minst 3 gånger.

Men jag lyckades fixa det viktigaste, mobilt bankid.

¤.¤


Vet inte om det var klokt att beställa senaste ajFån (SE version 2) eller ej. Men det gjorde jag igår. Leverans om en vecka.

Var det smart att köpa det i dessa tider?

Gjort är gjort. Det visar sig om det var klokt eller ej.

Min nuvarande (också en SE) har jag varit väldigt nöjd med, men den börjar gå allt sämre. Sen är det frågan om den ens funkar efter nästa version av programvaran.

Helst ville jag förstås ha den som hade flest och bäst kamera, men den var alldeles för dyr och alldeles för stor. Denna är snabbare och har bättre kamera och inte så stor. Den är visserligen större än min nuvarande, så jag får se hur det är att bära den. Det lär bli jackfickan när jag kör hoj.

F.ö. har jag fortfarande ont i nacken, huvudet, magen (annan typ av magvärk). Det känns att det är höften, men det är det inte riktigt, utan det är vänster sida av ländryggen.

Bamyl som hjälper mig bäst mot huvudvärk fick jag sluta med, då jag fick annan ty av magvärk. Dessutom började jag blöda näsblod. Jag kan få näsblod (pollenallergin) och ämnen i Bamyl & Treo förstärker det hela. Så jag fick sluta med Bamyl och huvudvärken är åter sämre.

Har fortsatt smörja mig med Linnex. Tror att det börjar bli dags att skicka efter en ny snart. Försökt att massera och stretcha. Det är fel tid att anlita naprapaten. Det blir svårt att hålla avstånd på minst 2 meter om man vill ha behandling! Får fortsätta titta mot hans lokal från lägenheten än så länge!

Har åter fått ont i halsen, så jag får fortsätta hålla mig borta från folk. Tempen är fortfarande under 35,5.

Pratade med en sköterska i Värnamo. Hon gick med att skicka tillbaka remissen till Jönköping. Visst jag får vänta ännu längre att komma till en ortoped, men som läget är så är bästa lösningen att skjuta det på framtiden och härda ut. Mina händer och fingrar är varken bättre eller sämre. Om det hela skulle leda till operation, ja, då är det helt fel läge för det.

Skatteåterbäring, skadeanmälan


Hade mejlkonversation med Nässjö (efter 18) igår. Jag råddes att göra en skadeanmälan med.

Självrisken är på 3000 kr. Så jag får se när jag kan lämna in hojen för tankbyte. Det skulle beställas en sådan. Har ingen bråttom, inte i Corona tider i alla fall.

Såg att jag fått tillbaka på skatten, så en del av skattebäringen kommer att gå till självrisken.

Har du provat att starta om?


Ja, det är ofta man ställer frågan: har du provat att starta om?

Skulle fixa en grej i morse. Loggade in, fixade det och sen tänkte redovisa tiden. Det gick inte. Kom inte in i modulen. Fick meddelade om att jag något har gått fel och jag ska kontakta administratören!

Provade annan webbläsare och fick samma fel. Det drog väldigt lång tid innan meddelandet kom upp.

Provade andra moduler. Kollade lönespecen, frånvaro & resetillägg. Kom in i dessa direkt.

Kollade loggen på applikationen och det om något om timeout när en viss SQL fråga hade ställts mot databasen 😦 Skit, det hamnade på mitt bord!

Försökte ställa samma fråga som det stod i loggen, men jag visste inte vad jag skulle fylla i variablerna så jag kunde inte joina tabellerna, men det gick att ställa fråga mot enskilda tabeller som var listad i frågan.

SQL Servern gick inte tungt heller. Provade på nytt och fångade frågan i activity monitor. Stoppade frågan och fick meddelandet att det tog mer är 109 sekunder. Det kan stämma.

Vad har hänt sedan igår? 2 jobb har gått på servern. Indexerings jobbet och checkdb. Inget av dessa hade returnerat fel

Kan något av dessa jobben sabbat databasen, eller har det kommit in skräp i någon av tabellerna?

Får vänta till måndag och kontakta leverantören tänkte jag.

Några timmar senare, tänkte prova att göra failover = starta om SQL Server tjänsten. Bättre att kolla det först. Ingen kan tidredovisa annars.

Startade om tjänsten medan jag var inloggad. Det gjordes failover och det blev stopp i systemet. Gjorde refreh på sidan och sen testade jag att redovisa tiden. Det gick galant 😀

Ingen korrupt databas alltså 🙂

Jag hade inte sett något fel i SQL loggarna så jag vet inte vad felet kan bero på. Kan det ha varit något på applikationsservern och fixat sig när jag kapade den gren den satt på? Får kolla mer i applikation serverns loggar på måndag.

Nu funkar det som det ska och jag kan koppla av 🙂 Omstart hjälper 😉

Tog hem väskorna


Gick till förrådet (garaget) och hämtade hem väskorna. Startade hojen som span fint 🙂

Har inte bestämt mig om jag ska ta en tur eller ej. Det kändes lite i halsen så jag tror inte att det är bra idé att ta en tur i kylan.

Hade tänkt att ha väskorna ute på altan, men bar ner det till förrådet istället.

Kunde inte låta bli


Kunde inte låta bli att tänka på jobbet, så då började jag göra det jag jag grubblade på.

Backupsystemet skapar temporära backupfiler under C:\ medan den tar translogsbackupen. Det har hänt att tjänsten inte varit tillgänglig/servern startats/SQL server tjänsten startas … då har dessa filer legat kvar på C:\ tills nästa backupen gått.

Vill inte riskera att fylla C:\. Risken att det händer är inte stor, men det kan hända. Det finns system som är duktiga på skyffla data.

Lösningen har varit enkel. Skapa en mapp på annan enhet, skapa registervärde och starta om tjänsten.

Har funderat på hur jag ska göra det via skript på ”alla” servrar.

Så nu har fixat skriptet och testkört på en burk.

Men har inte samma enhet som backup enhet och jag hittade ett skript som plockade ut adressen från registret. En lista tog jag ut.

Så på måndag ska jag fixa detta innan jag lägger på senaste CU på kvällen.

Putsade fönstren


Putsade fönstren nyss, fast bara på utsidan. Det underlättare att kunna gå ut och putsa, istället för att öppna fönstren, tycker jag.

Det lite kyligt att gå ut i shorts, men jag har fortfarande vinterpälsen kvar, så det var ingen större fara med det 😉

Färdig!


Då blev jag klar med flytt av databaser till VMDK från iSCSI 🙂
Tror att det var dryga 11 TB som jag flyttade runt på 3 helger (5 dagar/48 timmar eller så).

Det är bara resten av arbetet kvar att göra!

Tänkte passa på att lägga på senaste CU på utvecklingsmaskinerna, medan backuperna pågick på de burkar jag skulle pilla på idag.

AG maskinerna kom upp, men inte SQL server tjänsten. Det gick att kicka igång tjänsten, men det tog evigheter på sig.

Först tänkte jag att det kan vara något med patchen, att första omstarten beter sig så. Det gjorde visserligen inte på alla labbmaskiner som jag hade testat på i torsdags.

Så jag lade på patchen på de andra brukarna i AG med, men alla betedde sig på samma sätt.

Började kolla i loggarna. Samtliga klagade på iSCSI. Men vi har ju inte haft iSCSI diskarna kvar. Det var första helgen jag tog hand om utv, test och pp.

Startade en testmaskin AG. Samma visa där. Skit, vad är detta? Kan jag avaktivera iSCSI tjänsten? Då såg jag att SQL Server (och agenten) var beroende på den.

Googlade på fenomenet och lösningen var att dyka in i registret och rensa värdet i DependOnService. Sen funkade det som det skulle 🙂

Vilken miss 😦 Nu har jag lärt mig en sak till. Det var totalt 3 register hack som man behövt göra för att rensa bort all skräp.

Så då var det vara att lägga upp en lista och beta av denna register hack med. Men alla burkar hade inte detta värdet under DependOnService. Vissa hade inte ens DependOnService.

Tror att de burkar som fick sina diskar via SnapCenter från början inte hade det, eller, ja det rensades efter vid avinstallation av SnapCenter plugins, …

Det strulade när jag skulle ta bort servrarna från SnapCenter med, förstås! Men alla är borta därifrån. Men en del servrar behöver startas om för att ta bort spöken. Tror att bara de som avinstallerades ordentligt som hade kvar värdet i registret.

Det kan förstås vara så att värdet hade rensats om jag hade avinstallerat SnapDrive & SnapManager. Det kom jag tänka på nu. Så går det när man är stressad, … .

Så det som kvarstår (av detta arbete) är att avinstallera SnapDrive & SnapManger. Förhoppningsvis slipper jag omstart för att rensa bort spöken på burkarna. Det där kan jag göra på dagtid som tur är 🙂

Men så sagt hade jag kanske sluppit stulet om jag hade städat redan från början. Men då tror jag knappast att jag hade hunnit med migreringen som jag gjorde.

Det visar sig när jag ska börja städa i burkarna i veckan. Det kanske krävs omstarter, hoppas inte det.

Annars var det problem Analysis Services. Det var inte riktigt samma körschema som det jag hade kört i testmiljön. Det var äldre version i test.

I test hade jag gått efter ett körschema som jag hade hittat på på nätet och anpassat det efter all patrull jag åkt på.

I test flyttades bara en av OLAP mappar (under data) när tjänsten startades upp. Men inte det som fanns under tempdb, logg och backup mapparna.

I prod flyttades inte någon av dessa mappar. Så jag kopierade alla till rätt ställe, men då inte kom tjänsten upp inte.

Kom sedan på att jag inte tilldelat behörighet på mapparna. Borde ha använt mig av robocopy.

Så även Analysis Services kom upp till slut. Men jag visste inte hur jag testa det hela. Allt jag testade på hittade ingen data 😦 Få se om det funkar som det ska nästa vecka. Har en backup på ”databasen” annars.

Annars var samma strul som vanligt, större databaser fick SnapCenter någon typ av timeout på. Men databaserna skapades efter att jag flyttat loggen manuellt. I SCOMs fall, DW databasen, tog det nästan 2 timmar att skapa databasen, efter att jag flyttade logfilen! Så jag fick ta hand om de andra databaserna medan SnapCenter jobbade.

Det var jävla tur att jag upptäckte min miss och tog beroendet till iSCSI, annars hade AG maskinerna stått still efter omstart. Men som sagt kan ha sluppit det om jag hade avinstallerat SnapDrive, SnapManager, …

Nu ska jag försöka låta bli att tänka på jobbet. Det är inte lätt, det går bara runt i skallen, med allt som kvarstår att göra, allt jag gjort och de miss jag gjort och jag ska göra för att undvika det. Så jag maler och maler.

Kommer att ta ledigt till tisdag. Så är tanken i alla fall. Behöver ledigheten, samtidigt som jag vet att det finns uppgifter att göra, folk som står i kö, …

Få se om jag orkar åka till Nässjö och kolla på hojar imorgon. Få se hur magen mår.

Då var denna helgs arbete slutförd


Tar helg till imorgon!

Då var denna helgs arbete slutförd. 263 databaser flyttades runt (ca 4,7 TB).

Det var några väntade strul och några oväntade strul.

Drygt 20 timmar blev det denna helg (och under 20 timmar förra).

Tror att 2/3 delar är jag klar med 🙂

Fortsatte flytta på databaser


Såg nu att det nya backupsystemet skyddar 666 databaser 😀

Dagens skörd blev flytt av 1,8 TB (139 databaser på 6 servrar). Eller nja, ännu mera egentligen.

Flyttade system databaserna på 8 AG maskiner med. Få se om jag kan flytta användardatabaserna på AG maskinerna imorgon.

Tror att det är 2/3 av arbetet klart, morgondagen inräknat. Fortsätter nästa helg med, så det blir ingen resa till Uppsala och MC-mässan nästa vecka. Inte heller någon besök att kolla på nya hojar i Nässjö nästa lördag.

Självklart strulade det denna gången med. Mitt i flytt av databaserna på en viss maskin så tog disken slut och 9 databaser ”försvann”.

Använder det gamla backupsystemet att flytta på databaser. Den ska ta ner en databas i taget och flytta på filerna. Sen när filerna är klara så ska de jackas in i servern igen.

Men när disken tog slut, på en viss databas, så fortsatte kommandot till nästa och nästa och nästa, … tills den hade gått igenom listan på databasern.

Alla databaser hade detachats, men inte kunnat flyttas pga utrymmesbrist. Tur (eller skicklighet) att jag inte valde parametern som tar bort originalfilen när den är färdig med databasflytten!

Jag hade räknat fel på storleken. Den största databasen var hittills en klon från annan miljö. Den låg i egna mountpoints och jag hade räknat inte med den 😦 Klantigt!

Så inte så konstigt att disken tog slut.

Men filerna låg kvar i sin gamla enhet så jag kopierade dessa manuellt.

Tänkte göra restore på den största databasen, men den var borta från backupsystemet 😮

WTF? Jag hade tagit för lång tid på mig (mer än 15 minuter) och när backupsystemet inte hittade den databasen, så trodde den att den skulle tas bort.

Men jag hittade backupen i en annan flik. Den hade blivit relic och gick att återställa.

Fast då kom jag på att filerna låg kvar i en mountpoint så jag flyttade filerna manuellt och gjorde attach istället före restore.

Den sista servern krånglade med. När det var dags att flytta den största databasen så bröts kontakten och den orkade inte flytta log-filen. Så jag fick leta efter log-filen. Det tog sin lilla tid, tills jag hittade vilken databas som hade felat.

Skriptet skulle först skriva ut namnet på databasen innan den skulle började flytta på databasen. Men på vissa servrar så skriver den bara ut 3 bokstäver 😮 😦

Inte kul att leta efter en log-fil som börjar med WSS bland alla SharePoint databaser!

Men den hittade jag 🙂 Efter att jag lade dit den filen så fortsatte skriptet (kommando till den gamla backupsystemet) att fortsätta attacha databasen. Detta trots att skriptet hade körts färdig 😮

Strax innan 18 slutade jag, gick ut och käkade, tog en öl. Väl tillbaka loggade in och kollade att rullade på som det skulle.

Känner att det är dags att vila nu.