Strul


Det har varit lite struligt när jag försökt uppgradera SnapCenter idag.

Haft ett ärende hos supporten längre period. Har då och då kollat om det kommit en ny version.

Såg idag att det har kommit 4.1.1 P2 . Vi kör 4.1.1. Så jag skickade en fråga om jag ska installera denna version. Ja tack sa supporten.

I labb så gick det rätt så bra. Fick installera plugin 2 gånger på en host (kluster på 3 burkar). Var det för jag försökte installera det samtidigt på andra host tro?

Funderade om jag ska ge mig på att skripta skiten, nästa gång tänkte jag.

Bestämde mig att installera det i produktion med. Nä, samma fel trots att jag försökte installera en host i taget. En tjänsten uppgraderas, men inte pulginen (inte alla plugin) utan det står ogiltigt, så man får göra modify på nytt pch välja att lägga till plugin. Oftast handlade det om SQL Server plugin.

En enda host av 10 (20 servrar) gick bra, utan problem 😮

Vissa servrar fick jag installera plugin 3 gånger, annars räckte det med 2 gånger.

En server gjorde failover mitt i installationen 😦 Det var den viktigaste servern, enligt mig. Samma visa var det när 4.1.1 installerades. Så fr o m nu får uppgraderingen ske utanför arbetstid tycker jag.

En servern gick inte att nå alls. Hände nåt med nätet tro? Fick logga in på konsolen och starta om skiten. Det hjälpte inte i SnapCenter gui. Startade om SC servern med. Först då fick jag grönt på allt.

Skickade en del skärmdumpar till supporten med kort beskrivning av händelseförloppet.

Tänkte samla loggar med SnapGathers. Då brukar vilja ha det. Då nöp antivirus den senaste versionen med. Programmet tolkas om trojan! Så jag fick plocka bort SnapGathers på nytt.

Har börjat ledsna på SC.

Få se om den nya versionen har löst ärendet, eller om det kvarstår.

Supporten fick ett mejl till. SnapCenter vill att man ska ha PowerShell 4.0 installerat. Eller den senare version. Men PowerShell 5.0 (Win 2016) gillar den inte. Vill ha version 4.0 eller senare! Så supporten fick felmeddelandet och att version 5.0 är faktiskt senare än version 4.0! Det måste ha varit en hårdkodning. De borde lära att skriva större än eller lika med 4.0!

Kommentera

Fyll i dina uppgifter nedan eller klicka på en ikon för att logga in:

WordPress.com Logo

Du kommenterar med ditt WordPress.com-konto. Logga ut /  Ändra )

Google-foto

Du kommenterar med ditt Google-konto. Logga ut /  Ändra )

Twitter-bild

Du kommenterar med ditt Twitter-konto. Logga ut /  Ändra )

Facebook-foto

Du kommenterar med ditt Facebook-konto. Logga ut /  Ändra )

Ansluter till %s

This site uses Akismet to reduce spam. Learn how your comment data is processed.